nmcontrol on linux

Namecoin, NMControl
barkingdoggy
Posts: 36
Joined: Thu Jul 23, 2015 7:58 pm
os: windows

Re: nmcontrol on linux

Post by barkingdoggy » Thu Nov 05, 2015 12:28 am

Cannot seem to get nmcontrol listening on 127.0.0.1. Here's service-dns.conf:

Code: Select all

[dns]
; Launch at startup
;start=1

; Listen on ip
host=127.0.0.1

; Disable lookups for standard domains
disable_standard_lookups=1

; Listen on port
;port=53

; Forward standard requests to
resolver=8.8.8.8,8.8.4.4,
System dns is also 127.0.0.1. But after rebooting the machine and restarting namecoind and running: sudo python ./nmcontrol.py --debug=1
I still get this:

Code: Select all

nslookup isit.bit
Server:		127.0.1.1
Address:	127.0.1.1#53

Non-authoritative answer:
Name:	isit.bit
Address: 92.242.140.21
Suggestions?

phelix
Posts: 1631
Joined: Thu Aug 18, 2011 6:59 am

Re: nmcontrol on linux

Post by phelix » Thu Nov 05, 2015 9:34 am

barkingdoggy wrote: System dns is also 127.0.0.1. But after rebooting the machine and restarting namecoind and running: sudo python ./nmcontrol.py --debug=1
I still get this:

Code: Select all

nslookup isit.bit
Server:		127.0.1.1
Address:	127.0.1.1#53

Non-authoritative answer:
Name:	isit.bit
Address: 92.242.140.21
Suggestions?
does it work now with "nslookup isit.bit 127.0.0.1" ? It seems the issue is that the system (or nslookup at least) is still using 127.0.1.1 you could also try ping isit.bit or something
nx.bit - some namecoin stats
nf.bit - shortcut to this forum

barkingdoggy
Posts: 36
Joined: Thu Jul 23, 2015 7:58 pm
os: windows

Re: nmcontrol on linux

Post by barkingdoggy » Fri Nov 06, 2015 6:14 pm

Working now, sorta. :? nslookups work as long as I append 127.0.0.1 to the command. Ping and browser works for .bit and .com, etc. Nmcontrol debug log empty except for the launch sequence.

Here's the service-dns.conf file.

Code: Select all

[dns]
; Launch at startup
;start=1

; Listen on ip
host=127.0.0.1

; Disable lookups for standard domains
disable_standard_lookups=0

; Listen on port
;port=53

; Forward standard requests to
resolver=8.8.8.8,8.8.4.4,


.com names do not resolve if ";disable_standard_lookups=1"
.com names do not resolve if system DNS is set to 127.0.0.1.

phelix
Posts: 1631
Joined: Thu Aug 18, 2011 6:59 am

Re: nmcontrol on linux

Post by phelix » Fri Nov 13, 2015 11:02 am

barkingdoggy wrote:Working now, sorta. :? nslookups work as long as I append 127.0.0.1 to the command.
This is probably ok as nslookup is not always influenced by the system setting.
Ping and browser works for .bit and .com, etc. Nmcontrol debug log empty except for the launch sequence.

Here's the service-dns.conf file.

Code: Select all

[dns]
; Launch at startup
;start=1

; Listen on ip
host=127.0.0.1

; Disable lookups for standard domains
disable_standard_lookups=0

; Listen on port
;port=53

; Forward standard requests to
resolver=8.8.8.8,8.8.4.4,


.com names do not resolve if ";disable_standard_lookups=1"
yep, that is expected if you go through nmcontrol. maybe we should change the option to 'enable_standard_lookups' to make things simpler.
.com names do not resolve if system DNS is set to 127.0.0.1.
Hmm, above you wrote both .bit and .com work so I don't quite follow as .bit will not with the system DNS set to something other than the nmcontrol dns address.

If there are still issues please elaborate.
nx.bit - some namecoin stats
nf.bit - shortcut to this forum

cassini
Posts: 333
Joined: Sun May 26, 2013 6:36 pm

Re: nmcontrol on linux

Post by cassini » Fri Nov 13, 2015 3:04 pm

barkingdoggy wrote:debug log empty except for the launch sequence.
This was the behaviour before phelix made the latest commits. Now all the lookups messages should appear in log.txt.
Make sure
a) you've got the newest version (or simply delete the directory containing the old nmcontrol code, and git clone again;
b) you are looking at the right place for log.txt (if in doubt just delete the old log.txt before restarting nmcontrol);
c) you always try nslookup nx.bit 127.0.0.1 as a first test. This should always work, and appear in log.txt with something like this:

Code: Select all

...
2015-11-13 16:21:18,448 - serviceDNS - DEBUG - Lookup: {'query': '', 'domain': 'nx.bit', 'src_addr': ('127.0.0.1', 64995), 'qtype': 1, 'qclass': 1}
2015-11-13 16:21:18,448 - pluginNamespaceDomain - DEBUG - Resolving : nx.bit getIp4
2015-11-13 16:21:18,449 - backendDataNamecoin - DEBUG - BackendDataNamecoin: ['name_show', 'd/nx']
2015-11-13 16:21:18,453 - pluginData - DEBUG - Processing import for {u'map': {u'': u'178.248.244.15'}}
2015-11-13 16:21:18,453 - pluginNamespaceDomain - DEBUG - Possible domains : [[]]
2015-11-13 16:21:18,453 - pluginNamespaceDomain - DEBUG - Fetching ip for nx.bit in sub-domain []
2015-11-13 16:21:18,453 - pluginNamespaceDomain - DEBUG - * result:  {"ip": ["178.248.244.15"]}

biolizard89
Posts: 1977
Joined: Tue Jun 05, 2012 6:25 am
os: linux

Re: nmcontrol on linux

Post by biolizard89 » Mon Nov 16, 2015 2:34 am

cassini wrote:
barkingdoggy wrote:debug log empty except for the launch sequence.
This was the behaviour before phelix made the latest commits. Now all the lookups messages should appear in log.txt.
Make sure
a) you've got the newest version (or simply delete the directory containing the old nmcontrol code, and git clone again;
b) you are looking at the right place for log.txt (if in doubt just delete the old log.txt before restarting nmcontrol);
c) you always try nslookup nx.bit 127.0.0.1 as a first test. This should always work, and appear in log.txt with something like this:

Code: Select all

...
2015-11-13 16:21:18,448 - serviceDNS - DEBUG - Lookup: {'query': '', 'domain': 'nx.bit', 'src_addr': ('127.0.0.1', 64995), 'qtype': 1, 'qclass': 1}
2015-11-13 16:21:18,448 - pluginNamespaceDomain - DEBUG - Resolving : nx.bit getIp4
2015-11-13 16:21:18,449 - backendDataNamecoin - DEBUG - BackendDataNamecoin: ['name_show', 'd/nx']
2015-11-13 16:21:18,453 - pluginData - DEBUG - Processing import for {u'map': {u'': u'178.248.244.15'}}
2015-11-13 16:21:18,453 - pluginNamespaceDomain - DEBUG - Possible domains : [[]]
2015-11-13 16:21:18,453 - pluginNamespaceDomain - DEBUG - Fetching ip for nx.bit in sub-domain []
2015-11-13 16:21:18,453 - pluginNamespaceDomain - DEBUG - * result:  {"ip": ["178.248.244.15"]}
I assume everyone here is aware of this, but in case it's not totally obvious to everyone, logging data that includes what sites you visited is not safe for general use, and should only be used for debugging, with great care taken to cleanse logs before sharing. The software should explicitly warn the user if something like this is enabled.
Jeremy Rand, Lead Namecoin Application Engineer
NameID: id/jeremy
DyName: Dynamic DNS update client for .bit domains.

Donations: BTC 1EcUWRa9H6ZuWPkF3BDj6k4k1vCgv41ab8 ; NMC NFqbaS7ReiQ9MBmsowwcDSmp4iDznjmEh5

allthingsgo
Posts: 4
Joined: Fri Nov 13, 2015 8:43 pm
os: mac
Contact:

Re: nmcontrol on linux &/OSX ?

Post by allthingsgo » Tue Nov 17, 2015 4:04 pm

just wish to share a particularity on my OSX running namecoin-qt/nmcontrol/chrome browser of name resolve behavior:

when I get nmcontrol running and when network proxy/DNS setting on OSX system had entries other than 127.0.0.1,
when checking name resolve with nslookup on terminal appears to be problematic.
bash-3.2# nslookup nf.bit
;; Got recursion not available from 127.0.0.1, trying next server
;; Got recursion not available from 127.0.0.1, trying next server
Server: 8.8.8.8
Address: 8.8.8.8#53

in other words, with nmcontrol running, I had to make sure /etc/resolv.conf had only one entry 127.0.0.1 while add other opennic or google DNS service in ~/Library/Applicaiton\ Support/Nmcontrol/service-dns.conf file... :
[dns]
; Launch at startup
;start=1

; Listen on ip
host=127.0.0.1

; Disable lookups for standard domains
disable_standard_lookups=1

; Listen on port
port=53

; Forward standard requests to
;resolver=8.8.8.8,8.8.4.4
resolver=8.8.8.8,8.8.4.4,
id/allthingsgo ?

barkingdoggy
Posts: 36
Joined: Thu Jul 23, 2015 7:58 pm
os: windows

Re: nmcontrol on linux

Post by barkingdoggy » Wed Nov 18, 2015 8:05 pm

Making progress?! Turns out I had a couple of versions of nmcontrol on the machine and I was invoking an older version when the debug log file wasn't logging. Cleaned things up and cloned the latest commits. Now the debug log is working, and yes I need to set the DNS to 127.0.0.1 for nslookup to work as it should in resolving .bit and .com, .org. .etc. So all that is progress.

The issue now is that "Firefox can't find the server at" many URIs, like news.google.com and many others, even though nslookup works and the debug log looks ok. Attached is the log associated with 1) opening Firefox to its homepage (www.linuxmint.com/start/petra/) which opens fine, 2) then going to news.google.com which fails, 3) then going to nx.bit which opens fine.

I'm stumped. I don't know is this is a problem with nmcontrol, Firefox, Mint or otherwise. Suggestions?
Attachments
nmcontrol log.txt
(61.27 KiB) Downloaded 75 times

barkingdoggy
Posts: 36
Joined: Thu Jul 23, 2015 7:58 pm
os: windows

Re: nmcontrol on linux

Post by barkingdoggy » Wed Nov 18, 2015 9:38 pm

Same issues observed in Chromium browser as in Firefox. Opens some URIs and not others (e.g. wikipedia.org opens but news.google.com does not). Deleted the browser history in Firefox but no change.

phelix
Posts: 1631
Joined: Thu Aug 18, 2011 6:59 am

Re: nmcontrol on linux &/OSX ?

Post by phelix » Thu Nov 19, 2015 9:36 am

allthingsgo wrote:just wish to share a particularity on my OSX running namecoin-qt/nmcontrol/chrome browser of name resolve behavior:

when I get nmcontrol running and when network proxy/DNS setting on OSX system had entries other than 127.0.0.1,
when checking name resolve with nslookup on terminal appears to be problematic.
bash-3.2# nslookup nf.bit
;; Got recursion not available from 127.0.0.1, trying next server
;; Got recursion not available from 127.0.0.1, trying next server
Server: 8.8.8.8
Address: 8.8.8.8#53

in other words, with nmcontrol running, I had to make sure /etc/resolv.conf had only one entry 127.0.0.1 while add other opennic or google DNS service in ~/Library/Applicaiton\ Support/Nmcontrol/service-dns.conf file... :
[dns]
; Launch at startup
;start=1

; Listen on ip
host=127.0.0.1

; Disable lookups for standard domains
disable_standard_lookups=1

; Listen on port
port=53

; Forward standard requests to
;resolver=8.8.8.8,8.8.4.4
resolver=8.8.8.8,8.8.4.4,
Do I understand you correctly that things only work with a single system DNS entry? Probably this should be avoided.
barkingdoggy wrote:Making progress?! Turns out I had a couple of versions of nmcontrol on the machine and I was invoking an older version when the debug log file wasn't logging. Cleaned things up and cloned the latest commits. Now the debug log is working, and yes I need to set the DNS to 127.0.0.1 for nslookup to work as it should in resolving .bit and .com, .org. .etc. So all that is progress.

The issue now is that "Firefox can't find the server at" many URIs, like news.google.com and many others, even though nslookup works and the debug log looks ok. Attached is the log associated with 1) opening Firefox to its homepage (http://www.linuxmint.com/start/petra/) which opens fine, 2) then going to news.google.com which fails, 3) then going to nx.bit which opens fine.

I'm stumped. I don't know is this is a problem with nmcontrol, Firefox, Mint or otherwise. Suggestions?
Hmm the log looks ok to me. Also news.google.com work fine for me atm. I am now using the same setup and will try to reproduce the issue.
nx.bit - some namecoin stats
nf.bit - shortcut to this forum

Post Reply