FreeSpeechMe Tech Help

fwb3
Posts: 6
Joined: Wed Feb 19, 2014 6:54 pm
os: linux
Location: Texas
Contact:

Re: FreeSpeechMe Tech Help

Post by fwb3 » Fri Feb 21, 2014 4:59 am

I have an ubuntu 13.10 desktop with firefox 27.0.1. Installed freespeechme with no problems. Restarted firefox and saw namecoind process start up and begin downloading the blockchain. After 5 hours, I checked, and it wasn't able to resolve any .bit addresses still. I checked the namecoind status dialog, and the error portion of the stanza read...

"WARNING: Displayed transactions may not be correct! You may need to upgrade, or other nodes may need to upgrade."

The block count was up to 143113. I let it go another hour, and no change. I decided to restart firefox. I saw the namecoind process go away, and come back when I restarted firefox. No change. It's been several hours since, and still no change. The block count is still 143113, and the error message is still there.

Do I need to reinstall freespeechme?

fwb3
Posts: 6
Joined: Wed Feb 19, 2014 6:54 pm
os: linux
Location: Texas
Contact:

Re: FreeSpeechMe Tech Help

Post by fwb3 » Fri Feb 21, 2014 4:13 pm

fwb3 wrote:I have an ubuntu 13.10 desktop with firefox 27.0.1. Installed freespeechme with no problems. Restarted firefox and saw namecoind process start up and begin downloading the blockchain. After 5 hours, I checked, and it wasn't able to resolve any .bit addresses still. I checked the namecoind status dialog, and the error portion of the stanza read...

"WARNING: Displayed transactions may not be correct! You may need to upgrade, or other nodes may need to upgrade."

The block count was up to 143113. I let it go another hour, and no change. I decided to restart firefox. I saw the namecoind process go away, and come back when I restarted firefox. No change. It's been several hours since, and still no change. The block count is still 143113, and the error message is still there.

Do I need to reinstall freespeechme?
Tried removing and resinstalling freespeechme. No joy. Removing the extension from firefox doesn't remove the namecoind/nmcontrol and their related files. So, it just picked up with the same error where it left off. I'm trying to figure out that error message. Is it saying there is a more recent version of namecoind I should upgrade to? If so, how do I do that?

biolizard89
Posts: 1982
Joined: Tue Jun 05, 2012 6:25 am
os: linux

Re: FreeSpeechMe Tech Help

Post by biolizard89 » Sun Feb 23, 2014 3:58 am

Deafboy wrote:
biolizard89 wrote:
Deafboy wrote:I've just noticed a strange thing. I get "Namecoin: Verification success" in the browser even though the fingerprint on the web server does not match the one inside the blockchain.
Is it just accepting any fingerprint if the hostname in the cert is correct?
It should be checking the SHA1 fingerprint but not the Common Name. Can you please point me to a .bit domain which demonstrates the behavior you're seeing?
It's coinunity.bit
I have tried several fingerprints (due to my missunderstanding of how the whole convergence thing works) but the plugin always accepted every one of them as correct.
The problemis that I don't have an access to the webserver on the mentioned domain. I'll do more testing on my own server later.
coinunity.bit has the following fingerprint in the blockchain: 2709B0F4CA61B35342918BC070125F607D908B43 . That's the same fingerprint the server at https://83.167.250.85 is returning. So I don't see a bug. If you can point me to a .bit domain for which the server's fingerprint doesn't match the blockchain, which is still loading without any TLS error, please do.
Jeremy Rand, Lead Namecoin Application Engineer
NameID: id/jeremy
DyName: Dynamic DNS update client for .bit domains.

Donations: BTC 1EcUWRa9H6ZuWPkF3BDj6k4k1vCgv41ab8 ; NMC NFqbaS7ReiQ9MBmsowwcDSmp4iDznjmEh5

biolizard89
Posts: 1982
Joined: Tue Jun 05, 2012 6:25 am
os: linux

Re: FreeSpeechMe Tech Help

Post by biolizard89 » Sun Feb 23, 2014 4:01 am

fwb3 wrote:
fwb3 wrote:I have an ubuntu 13.10 desktop with firefox 27.0.1. Installed freespeechme with no problems. Restarted firefox and saw namecoind process start up and begin downloading the blockchain. After 5 hours, I checked, and it wasn't able to resolve any .bit addresses still. I checked the namecoind status dialog, and the error portion of the stanza read...

"WARNING: Displayed transactions may not be correct! You may need to upgrade, or other nodes may need to upgrade."

The block count was up to 143113. I let it go another hour, and no change. I decided to restart firefox. I saw the namecoind process go away, and come back when I restarted firefox. No change. It's been several hours since, and still no change. The block count is still 143113, and the error message is still there.

Do I need to reinstall freespeechme?
Tried removing and resinstalling freespeechme. No joy. Removing the extension from firefox doesn't remove the namecoind/nmcontrol and their related files. So, it just picked up with the same error where it left off. I'm trying to figure out that error message. Is it saying there is a more recent version of namecoind I should upgrade to? If so, how do I do that?
Usually that error means that your nameindex.dat is corrupt. Eventually I'll add an option to the GUI to fix this, but in the meantime, look in your profile folder, you should have a directory called .convergence-namecoin. Make sure Firefox, namecoind, and nmcontrol are closed, make a backup of that folder, and then delete that folder. Next time you run namecoind it will redownload the blockchain and regenerate nameindex.dat (it'll take 3-5 hours or so).

Let me know if that fixes it.
Jeremy Rand, Lead Namecoin Application Engineer
NameID: id/jeremy
DyName: Dynamic DNS update client for .bit domains.

Donations: BTC 1EcUWRa9H6ZuWPkF3BDj6k4k1vCgv41ab8 ; NMC NFqbaS7ReiQ9MBmsowwcDSmp4iDznjmEh5

fwb3
Posts: 6
Joined: Wed Feb 19, 2014 6:54 pm
os: linux
Location: Texas
Contact:

Re: FreeSpeechMe Tech Help

Post by fwb3 » Mon Feb 24, 2014 4:30 am

biolizard89 wrote: Usually that error means that your nameindex.dat is corrupt. Eventually I'll add an option to the GUI to fix this, but in the meantime, look in your profile folder, you should have a directory called .convergence-namecoin. Make sure Firefox, namecoind, and nmcontrol are closed, make a backup of that folder, and then delete that folder. Next time you run namecoind it will redownload the blockchain and regenerate nameindex.dat (it'll take 3-5 hours or so).

Let me know if that fixes it.
Deleting the .convergence-namecoin directory defnitely prompted namecoind to start building a fresh blockchain, but failed again after an hour or so.

{"version":37200,"balance":0,"blocks":39506,"timeoffset":0,"connections":8,"proxy":"","generate":false,"genproclimit":-1,"difficulty":516181.43689247,"hashespersec":0,"testnet":false,"keypoololdest":1393208474,"keypoolsize":101,"paytxfee":0,"mininput":0.0001,"errors":"WARNING: Displayed transactions may not be correct! You may need to upgrade, or other nodes may need to upgrade."}

I delete it and try again tonight. I'll post if success/failure.

fwb3
Posts: 6
Joined: Wed Feb 19, 2014 6:54 pm
os: linux
Location: Texas
Contact:

Re: FreeSpeechMe Tech Help

Post by fwb3 » Mon Feb 24, 2014 3:39 pm

fwb3 wrote: Deleting the .convergence-namecoin directory defnitely prompted namecoind to start building a fresh blockchain, but failed again after an hour or so.

{"version":37200,"balance":0,"blocks":39506,"timeoffset":0,"connections":8,"proxy":"","generate":false,"genproclimit":-1,"difficulty":516181.43689247,"hashespersec":0,"testnet":false,"keypoololdest":1393208474,"keypoolsize":101,"paytxfee":0,"mininput":0.0001,"errors":"WARNING: Displayed transactions may not be correct! You may need to upgrade, or other nodes may need to upgrade."}

I delete it and try again tonight. I'll post if success/failure.
Success! Third time's a charm. Would be curious to know what causes the corruption.

MWD
Posts: 180
Joined: Mon Feb 10, 2014 10:31 pm
os: windows
Contact:

Re: FreeSpeechMe Tech Help

Post by MWD » Mon Feb 24, 2014 5:55 pm

fwb3 wrote:
fwb3 wrote:
Success! Third time's a charm. Would be curious to know what causes the corruption.

Good you got it. Would love to know too, if you figure it out.

MWD
Namecoin, Dot-Bit and MeowBit are a complete new Internet ecosystem, building the roads to Web 4.0. http://www.meowbit.com
Dot-Bit Kitty Pix! The ONLY .bit-only kitty cat website in the world! http://dotbitkittypix.bit

biolizard89
Posts: 1982
Joined: Tue Jun 05, 2012 6:25 am
os: linux

Re: FreeSpeechMe Tech Help

Post by biolizard89 » Sun Mar 02, 2014 9:32 am

fwb3 wrote:
fwb3 wrote: Deleting the .convergence-namecoin directory defnitely prompted namecoind to start building a fresh blockchain, but failed again after an hour or so.

{"version":37200,"balance":0,"blocks":39506,"timeoffset":0,"connections":8,"proxy":"","generate":false,"genproclimit":-1,"difficulty":516181.43689247,"hashespersec":0,"testnet":false,"keypoololdest":1393208474,"keypoolsize":101,"paytxfee":0,"mininput":0.0001,"errors":"WARNING: Displayed transactions may not be correct! You may need to upgrade, or other nodes may need to upgrade."}

I delete it and try again tonight. I'll post if success/failure.
Success! Third time's a charm. Would be curious to know what causes the corruption.
Awesome, glad it worked for you. Based on what I've heard from snailbrain and Michael Gronager, it sounds like the libcoin rebase will eliminate the corruption issues (and also download the blockchain much faster). domob is hard at work on that effort.
Jeremy Rand, Lead Namecoin Application Engineer
NameID: id/jeremy
DyName: Dynamic DNS update client for .bit domains.

Donations: BTC 1EcUWRa9H6ZuWPkF3BDj6k4k1vCgv41ab8 ; NMC NFqbaS7ReiQ9MBmsowwcDSmp4iDznjmEh5

DataPacRat
Posts: 1
Joined: Wed Mar 05, 2014 8:26 pm
os: linux
Location: Niagara, Canada
Contact:

Re: FreeSpeechMe Tech Help

Post by DataPacRat » Wed Mar 05, 2014 8:35 pm

biolizard89 wrote:32-bit Linux doesn't work right now.
I'm currently using 32-bit Slackware; are there any plans for getting a 32-bit Linux version of FreeSpeechMe working in the near future?
Thank you for your time,
--
DataPacRat
"Then again, I could be wrong."

Meister
Posts: 1
Joined: Tue May 06, 2014 2:58 pm
os: linux

Re: FreeSpeechMe Tech Help

Post by Meister » Tue May 06, 2014 3:16 pm

Hello!
I'm currently trying to get the FreeSpeechMe addon working correctly in Linux. I'm running Arch Linux 64 bit with Firefox 29.0.
I've let the addon run for well over 5 hours but I cannot resolve any .bit address's I've tried. I continue to come up with the error "Namecoin Resolution Error: Failed to connect to nmcontrol -- -5961". After doing some digging, and trying to run firefox from a terminal, I found this error -
File "./nmcontrol.py", line 63
print "Exception when loading "+modType, module, ":", e
^
SyntaxError: invalid syntax

I look at my currently running programs, and sure enough nmcontrol isn't starting. I did a quick internet search but the only thing that seems to pop up is something about Python 3 not being compatable. I'm not sure how I would go about fixing this so I'm coming here for help, would love to use this addon. :)

If it helps, the addons I'm using now are Disconnect, Https everywhere, NoScript, RequestPolicy, GreaseMonkey, and Adblock Edge.

Thanks!

Post Reply